메뉴 바로가기

본문으로 바로가기



정보보호 권고

HOME > 정보센터 > 정보보호 권고

제목
Apache Struts2 원격 코드 실행 취약점 주의 권고
작성일 17.07.10
파일첨부 A3-AEGIS-20170710-001 [MIDDLE] Apache Struts2 원격 코드 실행 취약점 주의 권고.pdf

Apache Struts2 원격 코드 실행 취약점 주의 권고

 

□ 개요
 o Apache Struts
에서 임의 코드 실행이 가능한 취약점이 발견 [1]
 o
취약한 버전을 사용 중인 서버의 담당자는 악성코드 감염 등의 위험이 있으므로 대응방안에

따른 조치 권고
 
□ 내용
 o
웹 애플리케이션 Showcase ActionMessage.class에서 메시지를 처리할 때 특정 헤더 값을 통해

원격 코드 실행이 가능한 취약점(CVE-2017-9791)
 
□ 영향을 받는 제품 및 버전

 o Apache Struts 2.3.x
버전에서 Struts1 플러그인을 사용하는 경우
   
Apache Struts2 Struts 1 Action을 사용하기 위해 Struts1 플러그인 제공
 
□ 대응 방안
 o ActionMessage.class
에 메시지를 전달할 때 값을 직접 전달하는 대신 리소스 키를 사용하도록

권고함

이전글 한컴오피스 7월 정기 보안 업데이트 권고
다음글 CiSCO 제품군 다중 취약점 보안 업데이트 권고